[Sugar-devel] Tuxmath

James Cameron quozl at laptop.org
Tue Jun 2 21:42:56 EDT 2015

Summary: if you must deploy TuxMath, use TuxMath-3.1.xo with TuxMath
2.0.3 on Ubuntu, it works fine there.

On Tue, Jun 02, 2015 at 05:43:39PM +0200, Tony Anderson wrote:
> I tried to install TuxMath with:
> sudo yum --downloadonly --downloaddir=/home/olpc/Documents install tuxmath

No thanks, unsustainable, unsupported.  Supported method for OLPC OS
is to add tuxmath package to the build, make the build, and then
install it.  The .ini file would have:


But given my findings below, don't bother.

> This failed on an xo-1.75: (13.2.0) with the message Error: Cannot
> retrieve metalink for repository: fedora/18/armhfp

Check the clock is set to 2015.  Check your internet.  Try again.  It
worked for me on XO-1.75 13.2.3 today, so it should work also on

But given my findings below, don't bother.

> It also failed on an xo-1 (12.1.0): with the message Error: Cannot
> retieve metalink for repository: fedora

Check the clock is set to 2015.  Check your internet.  Try again.  It
worked for me on XO-1 13.2.4 today.

But given my findings below, don't bother.

> However, an xo-1.5 (13.2.1) downloaded three files:
>     SDL_net-1.2.8-2.fc18.i686.rpm
>     t4k_common-0.1.1-8.fc18.1686.rpm
>     tuxmath-2.0.1-3.fc18.i686.rpm
> I installed with
>    rpm -ivh *.rpm with no reported problems
> However, when I executed tuxmath:
>    $tuxmath
> it started. However, after a short while, I got a Segmentation
> fault.

Same here, many times.  Something is buggy.  2.0.1-3 is from Fedora
18.  Fedora 22 has 2.0.1-7, but it is a rebuild, no actual change.


I wondered if Fedora 18 updates would fix the problem.  But 13.2.4 on
XO-1 has all updates, and tuxmath still fails quickly.

> I thought that Nathan 

Nathan doesn't participate in sugar-devel@, so please CC.  Also, those
tests were on 13.2.4.

> installed these rpms and then ran the Tuxmath
> activity instead of running from the command line. I downloaded and
> installed tuxmath-2.xo.
> It failed to start because activity.info is not correct. I changed it to:
> exec = sugar-activity activity.TuxMathStart

In addition to what Gonzalo said in earlier reply, this need to change
the .info file was fixed for Sugar 0.105.0, so please upgrade.  What's
your upgrade plan?  Have you made sure the next version of Sugar will
meet your needs?


> After rebooting, I launched TuxMath successfully. However, when I
> clicked on 'play', nothing happened.
> The log showed an exception in activity.py at line 185:  f =
> open(script_path,'w') where script_path is None. The script_path
> variable is set at line 192 in
> the button_play_clicked_cb , as os.getenv("TUXMATH_SCRIPT"). The
> script that was to be executed calls a binary module in
> TuxMath.activity/bin. Hopefully, these modules were recompiled for
> ARM.

TuxMath-2.xo does have binaries for x86 only.

TuxMath-3.1.xo does not have binaries, so the above is not useful.

> I don't know how any of this relates to installing missing
> dependencies; however, it is clear that  tuxmath in ASLO is a no-go.

Yes, and ASLO clearly shows works with Sugar 0.82 to 0.94, so this is
not news.

The later TuxMath-3.1.xo is a no-go for me on XO laptops with the
Fedora package of TuxMath 2.0.1.  When it does manage to run for the
menus, it is laggy.

Also TuxMath-2.xo is a no-go for me on XO laptops.  This is a bundle
incompatible with Sugar 0.104 and later.  It was a binary repackaging
now five years old.

On the other hand, Tuxmath-3.1.xo with Tuxmath 2.0.3 works great in
Ubuntu, so chances are the fixes between 2.0.1 and 2.0.3 are needed in


James Cameron

More information about the Sugar-devel mailing list