[Sugar-devel] Issues loading datastore objects

Suraj K S suraj.gillespie at gmail.com
Tue Sep 10 10:07:11 EDT 2013

Hi Daniel,

Yep, loading objects created by the objectchooser activity is works fine.

When i created a text file using the 'Edit activity' and tried to load it
in the object chooser activity, it doesn't turn up there.
The on_data function isn't being called in the above case.


On 10 September 2013 15:38, Daniel Narvaez <dwnarvaez at gmail.com> wrote:

> Hello Suraj,
> I finally had a look to the issues you was having loading datastore
> objects, using the Object-Chooser activity to test.
> I run into a few bugs:
> 1 gwebsockets is trying to convert binary data to utf-8 which obviously
> fails
> 2 When loading objects created by native activities we try to put a binary
> property in the json unencoded. I suspect that's preview. We will need to
> encode some properties before converting them to json there.
> 3 Sometimes we seem to get a "" file from the datastore API. Not sure what
> is going on there, needs debugging
> On the other hand, loading an object created by the ObjectChooser activity
> itself seems to work fine.
> Now, all the bugs I reproduced seems different from what you have been
> seeing. Could you explain exactly how you have been testing? In particular,
> which activity created the objects you are trying to open?
> --
> Daniel Narvaez
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sugarlabs.org/archive/sugar-devel/attachments/20130910/7f55a746/attachment.html>

More information about the Sugar-devel mailing list