[Sugar-devel] [IAEP] Running sugar at almost-native speeds in Windows

Ton van Overbeek tvoverbeek at gmail.com
Fri Mar 13 09:51:52 EDT 2009

On Thu, Mar 12, 2009 at 9:55 PM, S Page <skierpage at gmail.com> wrote:
> On Thu, Mar 12, 2009 at 4:04 PM, Dave Bauer <dave.bauer at gmail.com> wrote:
>>  I haven't found an easy way to get QEMU working with acceleration on OS X.
> QEMU on Windows is also confused, or I am.
> http://sugarlabs.org/go/Supported_systems/Windows still points to
> Wade's fine bundle and detailed steps from Ton van Overbeek  but both
> are to run OLPC 8.2.0 images which is old Sucrose.
> Meanwhile http://wiki.laptop.org/go/Emulating_the_XO/Quick_Start/Windows
> and its parent have lots of information about QEMU, but mostly
> out-of-date.
> I put today's SoaS2 ISO in my dusty old qemu 0.9.0 directory on
> Windows XP.  I think you use "-cdrom Soas2-200903121944.iso" to make
> it work.
> C:\Qemu> net start kqemu
> The KQEMU virtualisation module for QEMU service was started successfully.
> C:\Qemu>qemu.exe -L . -m 256 -kernel-kqemu -soundhw es1370 -net user
> -net nic,model=rtl8139 -cdrom Soas2-200903121944.iso
> Version mismatch between kqemu module and qemu (00010400 00010300) -
> disabling kqemu use
> Maybe that's why it's mind-blowingly slow to boot.

Note there is a break between qemu 0.9.1 and later w.r.t which kqemu
module to use.
See http://www.nongnu.org/qemu/download.html.
kqemu 1.3.0pre11 for qemu <= 0.9.1
kqemu 1.4.0pre1 for later (i.e. my private version and for 0.10.1)

> QEMU 0.10 is out, but the two Japanese URLs don't have Windows
> binaries.  Some random person at
> http://qemu-forum.ipi.fi/viewtopic.php?f=5&p=14435 has a Windows
> build, while a compatible kqemu accelerator is nowhere to be found.

I always had problem with -kernel-kqemu. Usually things work with only user
mode acceleration. I did try the 0.10 version you referenced with
but the boot only worked up to the start of X, then it crashed.
Have not tried the 20090312 version yet.

> There is a QEMU 0.9.1 Windows binary, I don't know if available kqemu
> works for it.
> Emulating OLPC OS Images with QEMU has been difficult on any platform
> ever since the 3DNow! extensions problem arose, I think that's why
> Wade and Ton van Overbeek made special binaries.  But maybe old
> versions of qemu/kqemu are fine for SoaS images.
>> I think we are working towards a solution, just not as quickly as we would
>> like.
> The story of the life since the Industrial Revolution ;-)
> Regards,
> --
> =S Page

I will be off-line till April 10 (holidays down-under), but then I should have a
shining new 17 inch MacBook Pro with VMWare Fusion, so I should be able
to try out both Windows and Mac versions.

Ton van Overbeek

More information about the Sugar-devel mailing list