[Sugar-devel] Quick run through of Activities on Soas2-200903061846

Bert Freudenberg bert at freudenbergs.de
Thu Mar 12 06:22:43 EDT 2009

On 12.03.2009, at 05:18, Gary C Martin wrote:

> Environment: VirtualBoxVM running on an Intel Mac
> SoaS: Soas2-200903061846
> Build: Fedora release 10.91 (Rawhide)
> Sugar: 0.84.0

I tried this again, in WMWare Fusion on Mac.

On first boot, I got the "no loop device found" error.

On second boot, it worked fine.

One thing I noticed when shutting down is that the CD drive is still  
locked, which VMWare complains/warns about.

> Etoys-100: Fails, line 77: exec etoys: not found

Did you install Etoys yourself? AFAICT it is not pre-installed yet.  
SoaS-2 is still missing the "etoys" glucose module, so the fructose  
"Etoys" won't work.

Basically, the stand-alone Etoys.xo is only useful on raw OLPC builds,  
which only ship glucose but not fructose.

> Scratch-12: exec: /usr/bin/squeak: cannot execute: No such file or  
> directory

This depends on the squeak virtual machine, which would have been  
pulled in by the etoys rpm if it was installed.

Thanks for testing and reporting back!

- Bert -

More information about the Sugar-devel mailing list