[Sugar-devel] [SoaS] Booting SoaS on a PC and on an XO with the same stick (Yes, it can be done)

Ton van Overbeek tvoverbeek at gmail.com
Tue Mar 10 14:11:48 EDT 2009

On Tue, Mar 10, 2009 at 11:34 AM, Dave Bauer <dave.bauer at gmail.com> wrote:
> Hi, I used liveusb-creator 3.6.3 on windows to create SoaS-20090305 and it
> works fine on my Acer laptop, and virtualbox.
> I tried to boot from the USB with my XO and I got "no signature for our key
> list found"
> I have my developer key installed in /security/develop.sig
> I also tried copying the key to /security/develop.sig on the USB but got the
> same message.
> Is there a step to get the SoaS to boot on the XO that I am missing?
> Thanks
> Dave

What does a verbose boot on your XO say (Keep the 'v' game key pressed
when powering
the XO on until asked to release the game keys) ?
Open Firmware should report finding your developer key before even
trying to load the ramdisk
and booting linux.
Also make sure your stick has not been booted on an other computer
before booting on the XO
(i.e. first boot after creating the stick with liveusb-creator on the XO).
Alernatively you have to delete (as root) /.liveusb-configured and
/.liveusb-late-configured before
shutting down and then boot on your XO.
Right now I can only say, it works for me ...

Ton van Overbeek

More information about the Sugar-devel mailing list