[Sugar-devel] Activityfactory: rename activity_id to instance_id

Bert Freudenberg bert at freudenbergs.de
Wed Dec 3 15:28:51 EST 2008

On 03.12.2008, at 18:56, Jameson Quinn wrote:

> I had a brief chat with marco on IRC about activity_id. This is  
> stored in the datastore, unpacked to activityhandle data structure,  
> and used to identify an instance in a way that persists across  
> resumes. I think instance_id is a much better name for such a thing,  
> and would be willing to make the patch (basically just a global  
> search-and-replace).

It is better, yes. Also, service_name should be renamed bundle_id.

> Marco says that the this is part of a larger mess, and so he seemed  
> more interested in redesign than in such small tinkering. I think  
> that it's not an either/or choice: tinkering helps redesign, it  
> doesn't get in the way. He suggested I discuss it on the ML, so here  
> I am. The other possible issue is if this is API which is used by  
> any activities: I really think not, and I'll do my best to check,  
> but if you know of anything please say so.

The one place where "activity id" is visible in the API is as the "-- 
activity-id" command line argument:


which I would recommend not to change.

> If you want to use this thread to talk about the larger issues,  
> please do, it is an important discussion. But don't forget to opine  
> on whether I should do this one little patch.

I think it would make the current design more easy to follow, which  
would be good when thinking about a redesign.

Btw, for the id problem you noticed on IRC there is an old bug open:


- Bert -

More information about the Sugar-devel mailing list