[Sugar-devel] Activityfactory: rename activity_id to instance_id

Jameson Quinn jameson.quinn at gmail.com
Wed Dec 3 12:56:17 EST 2008

I had a brief chat with marco on IRC about activity_id. This is stored in
the datastore, unpacked to activityhandle data structure, and used to
identify an instance in a way that persists across resumes. I think
instance_id is a much better name for such a thing, and would be willing to
make the patch (basically just a global search-and-replace).

Marco says that the this is part of a larger mess, and so he seemed more
interested in redesign than in such small tinkering. I think that it's not
an either/or choice: tinkering helps redesign, it doesn't get in the way. He
suggested I discuss it on the ML, so here I am. The other possible issue is
if this is API which is used by any activities: I really think not, and I'll
do my best to check, but if you know of anything please say so.

If you want to use this thread to talk about the larger issues, please do,
it is an important discussion. But don't forget to opine on whether I should
do this one little patch.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.sugarlabs.org/archive/sugar-devel/attachments/20081203/fb970b2b/attachment.htm 

More information about the Sugar-devel mailing list