[sugar] Cairo build autogen.sh fails is TERM=dumb in emacs shell window

Marco Pesenti Gritti mpg
Sun Apr 29 17:59:41 EDT 2007

On Sun, 2007-04-29 at 08:04 -0700, Don Hopkins wrote:
> I ran across the following problem when trying to run "sugar-jhbuild 
> build" in an Emacs shell window, whose terminal type was set to "dumb" 
> by default:
> When it tried to build Cairo and ran "./autogen.sh --prefix ...", that 
> shell script returned immediately with an error code without producing 
> any output.
> The problem was on the line that went:
> boldface="`tput bold 2>/dev/null`"
> That was failing because the terminal type was set to "dumb".
> Once I set the terminal type to "vt100" it worked, though.
> Apparently "tset" fails if the terminal type does not support bold 
> highlighting, which causes the autogen script to fail.
> It looks like a lot of the different packages use "tput" in their 
> autogen.sh scripts:
> caio, dbus-glib, poppler, pyabiword, pycairo, pygobject, pygtk
> Maybe it would be a  good idea to leave fragile useless bells and 
> whistles like escape codes for terminal highlighting out of the 
> configuration and build process.

This one should be reported upstream (http://bugzilla.gnome.org)


More information about the Sugar-devel mailing list