[sugar] Studly caps

Marco Pesenti Gritti mpg
Thu Jul 20 08:52:27 EDT 2006


the presence service is now using studly caps in package names and in 
signal names. We should really have a convention about this...

There are a few of things I don't like that much about using studly caps 

- Using studly caps only for class names was giving some clue of what 
was a class and what a package.
- The gtk/glib convention for signals is to use - instead and since we 
are using those heavily we would have to mix styles.
- What should we do for single word package/signals? I guess they should 
use caps too but... it's sort of ugly.

I don't have such a strong feeling about the specific convention... but 
we should really make our conventions clear and use them consistently.


More information about the Sugar-devel mailing list