[Bugs] #3388 sugar-toolkit-gtk3 UNSP: The toolbar height with the gtk3 theme is smaller than in the gtk2 theme
Sugar Labs Bugs
bugtracker-noreply at sugarlabs.org
Fri Jun 8 16:45:33 EDT 2012
#3388: The toolbar height with the gtk3 theme is smaller than in the gtk2 theme
------------------------------------------+---------------------------------
Reporter: godiard | Owner: godiard
Type: defect | Status: assigned
Priority: Unspecified by Maintainer | Milestone: 0.96
Component: sugar-toolkit-gtk3 | Version: Unspecified
Severity: Major | Keywords:
Distribution: OLPC | Status_field: Unconfirmed
------------------------------------------+---------------------------------
Comment(by godiard):
Before trying this change, I have tried adding padding to the toolbar.
It's possible solve the the toolbar size applying a padding of 3, but the
problem is with the lines we use when the subpalette is down; the left,
top and right sides of the button are separated of the lines drawn in the
subtoolbar.
I couldn't find why the value of 7 is ok, when in the old (gtk2) theme 6
was the value selected. I found many differences, the button had a
property inner-border, but apparently is set to 0. In the old theme there
are also "fake" definitions as:
{{{
# We fake the default border in the theme
GtkButton::default-border = { 0, 0, 0, 0 }
GtkButton::default-outside-border = { 0, 0, 0, 0 }
GtkButton::image-spacing = $subcell_size
}}}
or
{{{
style "toolbutton"
{
xthickness = 0
ythickness = 0
GtkButton::inner-border = { $toolbutton_padding,
$toolbutton_padding,
$toolbutton_padding,
$toolbutton_padding }
GtkWidget::focus-padding = 0
...
engine "sugar" {
max_radius = 5.0
fake_padding = $default_padding
}
}
}}}
Another confussing issue is we have a variable toolbutton_padding but is
only used to:
{{{
BrowseNotebook.notebook tab .button {
border-radius: $(toolbutton_padding)px;
}
.toolbar GtkToolButton .button,
SugarPaletteWindowWidget SugarRadioToolButton *,
SugarPaletteWindowWidget GtkToolButton .button{
background-color: transparent;
border-radius: $(toolbutton_padding)px;
padding: $(default_padding)px;
}
SugarPaletteWindowWidget SugarRadioToolButton *:active {
background-color: @button_grey;
border-radius: $(toolbutton_padding)px;
}
.toolbar GtkToolButton .button:active {
background-color: @button_grey;
border-radius: $(toolbutton_padding)px;
}
}}}
then should be better rename it to "border_radius"
In the same way, "default_padding" is used in:
{{{
.notebook {
background-color: @selection_grey;
padding: 0px;
-GtkNotebook-tab-overlap: -2;
-GtkNotebook-tab-curvature: $default_padding;
}
.toolbar GtkToolButton .button,
SugarPaletteWindowWidget SugarRadioToolButton *,
SugarPaletteWindowWidget GtkToolButton .button{
background-color: transparent;
border-radius: $(toolbutton_padding)px;
padding: $(default_padding)px;
}
}}}
may be we should rename it.
But anyway all this does not explain why the value has not changed in the
75 theme. A rounding issue maybe?
--
Ticket URL: <http://bugs.sugarlabs.org/ticket/3388#comment:5>
Sugar Labs <http://sugarlabs.org/>
Sugar Labs bug tracking system
More information about the Bugs
mailing list