[sugar] frame redesign

Marco Pesenti Gritti mpgritti
Fri Feb 29 20:48:36 EST 2008


On Fri, Feb 29, 2008 at 4:59 AM, Tomeu Vizoso <tomeu at tomeuvizoso.net> wrote:
> Hi Marco,
>
>  have started moving the items in the frame around as Eben defined.
>
>  Can you give it a look and tell me what you think?
>
>  http://dev.laptop.org/git?p=users/tomeu/sugar;a=summary
>
>  First commit is "ClipboardBox to ClipboardTray. Make it a VTray
>  instead of hippo.CanvasBox.".

Hello,

here are some notes which I put together this morning on the train.
Traveling tomorrow, it will probably take a couple of days for me to
follow back, be patient :)

f8377e2c1a3db420cd00b0ca8f33f46a4314efd4

+        return True;

Patch looks fine. Please fix the ; above while you are changing that code.

3a608219960657a4b3d087306affb9b08ebe1c14

OK.

d7336f7358eba894616f47e32d8061bad6a3e4f0

Talked with Eben. The zoom buttons should actually stay in a toolbar. The
activity icons should be in a separate Tray, on the right of the zoom toolbar.
That way if activities scroll, the zoom buttons stays in screen.

0ad5327f664e49ce7e32fee4deb307165c5e7732

+        if new_level == ShellModel.ZOOM_MESH:
+            self._mesh_button.props.active = True
+        elif new_level == ShellModel.ZOOM_FRIENDS:
+            self._groups_button.props.active = True
+        elif new_level == ShellModel.ZOOM_HOME:
+            self._home_button.props.active = True
+        elif new_level == ShellModel.ZOOM_ACTIVITY:
+            self._activity_button.props.active = True

I think we should start using the new style gobject properties in new code.

There will be conflicts with the Tray vs Toolbar thing in the previous one.

af16fc5b4c2b15bee68656867355883146f07030
d61258768b33d8bb646c6bdf159ad46bc9059f19

What problems do you have there? I'll just note that sometimes it's easier
to use toggle buttons then radio, not sure if this is the case.

f0689cc5bde7235ce73be14414a2648070215959

        activitiestray.py               \
+       activitiestray2.py              \

I suppose the 2 is temporary. Any reason to do this? The rename will mess up
the history. Hmm, I guess I'm confused by this one, You are modifying both
versions of the tray and I'm not sure which one we are going to use...

3677745a10fbc7481fa1da02bd7b4c63e28d0deb

+        if home_activity.props.launching:
+            palette = Palette(_('Starting...'))
+            palette.props.invoker = FrameWidgetInvoker(self)
+            palette.set_group_id('frame')
+            self.set_palette(palette)
+
+            #self._start_pulsing()
+            home_activity.connect('notify::launching',
self._launching_changed_cb)
+        else:
+            self._setup_palette()

Maybe it would be cleaner to have the launching case inside _setup_palette too?

1c2ce9f1c374e85b3174a6a8868cb6fad15cb715

-        self.props.icon_name = name
+        self.get_icon().props.icon_name = name

Can we fix the toolkit and make this:

self.icon.props.icon_name = name

(should get even more convenient if we start using the new style gobject props).

+        view = deviceview.create(device)
+        self.pack_end(view, expand=False, fill=False, padding=0)

I'd rather pack_end the container then each widget, if that works as well.

+        """
         activities_tray = activitiestray2.ActivitiesTray(self._shell)
         panel.append(hippo.CanvasWidget(widget=activities_tray),
hippo.PACK_EXPAND)
+        """

Please remove this.

Thanks,
Marco



More information about the Sugar-devel mailing list