[sugar] Installing Sugar on Ubuntu 6.06 Linux.

Osmo Maatta osmoma
Fri Aug 25 11:14:25 EDT 2006

Hello all,

I just installed Sugar on my Ubuntu Linux desktop.

I encountered following issues:

When running
$ cd /home/moma/sugar-jhbuild/
$ ./sugar-jhbuild

1)  Error: Cannot create directory `/home/ruan'. Permission denied.   (hard
coded directory name).

make   install
Making install in src
make[1]: Entering directory
make[2]: Entering directory
test -z "/home/ruan/sugar/sugar-jhbuild/build/bin" || mkdir -p --
mkdir: cannot create directory `/home/ruan': Permission denied
make[2]: *** [install-binPROGRAMS] Error 1
make[2]: Leaving directory
make[1]: *** [install-am] Error 2
make[1]: Leaving directory
make: *** [install-recursive] Error 1
*** error during stage install of matchbox-window-manager: Error running
make   install *** [9/15]

  [1] rerun stage install
  [2] ignore error and continue to done
  [3] give up on module
  [4] start shell

Notice that my home directory is in /home/moma/.

I solved this problem by creating a temporary "/home/ruan" directory.

$ sudo mkdir /home/ruan
$ sudo chmod 777 /home/ruan

And it compiled and installed OK.
It put many files in "/home/ruan".

2)   error during stage configure of matchbox-window-manager:....[9/15]

XFixesShowCursor  error...

I got this error message several time.

I downloaded and installed newer libxfixes3 and libxfixes-dev from
Actually these packages belong to next version of Ubuntu (Edgy Eft).

But those packages caused many other errors.  So I had to remove them and
download / re-install the original Ubuntu Dapper packages from

$ dpkg -i --force-all *.deb

This obviously the same as
$ sudo apt-get install --reinstall libxfixes-dev  libxfixes3

And Sugar was happy. It compiled and installed OK.
At the moment, I have no explanation why it worked after re-installation of
those packages.

3) Running Sugar:
I copied all files from (the hard-coded) location
to my working area

$ cd /home/moma/sugar-jhbuild
$ cp -r /home/ruan/sugar/sugar-jhbuild/* .

It copied a "build" directory.

How to run Sugar ?

$ cd /home/moma/sugar-jhbuild
$ ./sugar-jhbuild run

It shows me this picture:  http://bildr.no/view/9288  (a screenshot)
The gecko browser is working well.

Is this the entire Sugar?
What else should I see in the Sugar sreen ?

Many thanks,
  // moma

This distro is:

$ uname -a
Linux moma-desktop 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006
i686 GNU/Linux

$ cat /etc/*release*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.laptop.org/pipermail/sugar/attachments/20060825/ff80fa5c/attachment.html

More information about the Sugar-devel mailing list