[Systems] [Sugar-devel] Broken ASLO mirrors

James Cameron quozl at laptop.org
Tue Aug 12 00:49:34 EDT 2014

On Mon, Aug 11, 2014 at 10:54:32PM -0400, Bernie Innocenti wrote:
> +rralcala
> On 08/11/2014 03:48 AM, Sam P. wrote:
> > Hi James,
> > 
> > I tried downloading the file from my mirror (sgp1.old.aslo.cf
> > <http://sgp1.old.aslo.cf>) and it worked a charm.  The Arrnet http
> > mirror is more than 1 month old!  Maybe change your code (just for this
> > run) to use the address of my mirror instead of download.sugarlabs.org
> > <http://download.sugarlabs.org> so you don't get arrnet. Stats (now
> > correct!) are here: http://mirrors.sugarlabs.org
> > 
> > +bernie, I thought mirrorbrain managed this stuff :(
> I thought so too!
> Roberto, since you're now familiar with mirrorbrain, would you mind
> checking what's going on? If it's not easy to figure out, just disable
> the outdated mirror.

The localhost wget problem appears to be resolved for the moment, or
was intermittent.  A wget executed on sunjammer was HTTP 302
redirected to mirrors.mit.edu, although sunjammer itself would be more

The wget from my desktop in Australia continues to redirect to broken
mirror, which is "correct" as far as mirrorbrain is concerned.

The sunjammer GeoIP database hasn't been updated since 2009-10-09.  I
suggest checking that geoip-lite-update is called by cron.

The GeoIP database correctly returns -- for, NA for (sunjammer), and OC for mirror.aarnet.edu.au and my own

quozl at sunjammer:~$ geoiplookup_continent -f /var/lib/GeoIP/GeoIP.dat
quozl at sunjammer:~$ geoiplookup_continent -f /var/lib/GeoIP/GeoIP.dat sunjammer.sugarlabs.org
quozl at sunjammer:~$ geoiplookup_continent -f /var/lib/GeoIP/GeoIP.dat
quozl at sunjammer:~$ geoiplookup_continent -f /var/lib/GeoIP/GeoIP.dat mirror.aarnet.edu.au
quozl at sunjammer:~$ geoiplookup_continent -f /var/lib/GeoIP/GeoIP.dat 121.212.117.x

It wasn't possible to check the mirrorbrain configuration.

quozl at sunjammer:~$ mb list
Traceback (most recent call last):
  File "/usr/bin/mb", line 1677, in <module>
    r = mirrordoctor.main()
  File "/usr/lib/pymodules/python2.6/cmdln.py", line 249, in main
  File "/usr/bin/mb", line 79, in postoptparse
    self.config = mb.conf.Config(conffile = self.options.configpath, instance = self.options.brain_instance)
  File "/usr/lib/pymodules/python2.6/mb/conf.py", line 47, in __init__
    self.general = dict(cp.items('general'))
  File "/usr/lib/python2.6/ConfigParser.py", line 564, in items
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'general'
1!quozl at sunjammer:~$ 



James Cameron

More information about the Systems mailing list