[Sugar-devel] sugar-runner stop working?

Samson Goddy samsongoddy at gmail.com
Sun Jan 6 08:39:32 EST 2019

Hello all,

I was trying to install sugar alongside my Fedora 28. I keep getting this error
message <https://paste.fedoraproject.org/paste/EuET1TMLbn3K6eCcvcpSSg>[1],
At first, I tried to fix it by doing the following;

On sugar-runner to specify the version.

27. import gi

29. gi.require_version('SugarRunner', '1.0')

48. gi.require_version('GTK', '3.0')

On xephyr-window

20. import gi

22. gi.require_version('SugarRunner', '1.0')

on xinitrc

24. import gi

26. gi.require_version('SugarRunner', '1.0')

After adding the following, I ran into this error

Am I missing something?


Samson Goddy

Twitter: https://twitter.com/samson_goddy
Email: samsongoddy at sugarlabs.org
            samsongoddy at gmail.com

Website: https://samsongoddy.me/  <https://www.sugarlabs.org/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sugarlabs.org/archive/sugar-devel/attachments/20190106/1192ca17/attachment.html>

More information about the Sugar-devel mailing list