[Sugar-devel] An error occurred while installing json (1.8.6), and Bundler cannot continue. Make sure that `gem install json -v '1.8.6'` succeeds before bundling

James Cameron quozl at laptop.org
Mon Nov 20 05:18:48 EST 2017

On Mon, Nov 20, 2017 at 10:34:59AM +0100, Samson Goddy wrote:
> I fixed the first problem, using the link
> http://blog.mclaughlinsoftware.com/2015/04/10/install-ruby-on-fedora/

Interesting, thanks.  Can't see how that page is connected to the
problem, but if it worked, great.

> But at the same time, the problem was from Fedora itself, they have
> issues with
> gcc: error: /usr/lib/rpm/redhat/redhat-hardened-cc1: No such file or directory
> So i fixed it with this command sudo dnf install redhat-rpm-config
> But now i am stuck here too.. By laptop power is down.. I have little power
> problems
> [samson at localhost www-sugarlabs]$ jekyll serve --incremental
> WARN: Unresolved specs during Gem::Specification.reset:
>       listen (~> 3.0)
> WARN: Clearing out unresolved specs.
> Please report a bug if this causes problems.
> /home/samson/.gem/ruby/2.4.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:313:in
> `check_for_activated_spec!': You have already activated addressable
> 2.5.2, but your Gemfile requires addressable 2.5.0. Prepending
> `bundle exec` to your command may solve this. (Gem::LoadError)

Gemfile.lock was written back around 29th August, and since then the
available version of "addressable" has changed to 2.5.2 for you, yet
the file specifies an exact match of 2.5.0.

Just a wild guess, but on the assumption that the API has not changed
since 2.5.0, you might change line 10 of Gemfile.lock to read ">=
2.5.0" instead of "2.5.0"

@geekrypter, Seetarama, does this seem reasonable?

> [...]
> Anyone with good insight could point things out, afterwards we can
> update the README.md file.

As you wish.

James Cameron

More information about the Sugar-devel mailing list