[Sugar-devel] Getting a few errors when following tutorials given in the Write your Own Activity page

mukund code mukund.code at gmail.com
Mon Jan 18 01:24:44 EST 2016

Hi guys,

I am new to Sugar. I am currently going through the tutorial posted here:

I created a sample activity(using exactly the same instructions given in
the tutorial). In the console, I noticed the following error:

Error: Load timeout for modules: webL10n
(anonymous function)

I tried:
volo add webL10n

It gave me a 301 error.

I then tried:
volo add https://github.com/fabi1cazenave/webL10n

which successfully installed webL10n. But the error still appears in the

Also, I am not able to load any dynamic content using mustache(despite
having a successful volo add) or console log out a statement when
"my-button" ( https://developer.sugarlabs.org/activity.md.html#first%20steps)
is clicked. I guess all of this is possible once js/activity.js. That
loading happens via lib/require.js. But that script is giving me this
error. I don't see any failed fetches in the Network tab of the console
window also.

Would be glad if someone helped out.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sugarlabs.org/archive/sugar-devel/attachments/20160118/40abc056/attachment.html>

More information about the Sugar-devel mailing list