[Sugar-devel] Tuxmath on 0.96+ mystery

lionel at olpc-france.org lionel at olpc-france.org
Thu Mar 28 03:55:03 EDT 2013

>> exec = sugar-activity tuxmath-activity
>> Once this correction done, the activity works normally !
> I don't believe you :P
> The correct exec line is
> exec = sugar-activity activity.TuxmathStart

You must believe me !
Try to do this:
1) Install official 12.1.0 on an XO-1 or XO-1.5
2) Download the latest Tuxmath version from the Sugar App Store
3) Install it and launch it: it don't work
4) Update the ativity.info exactly like me
5) Launch it again: it works. Not only the home page, the whole game!

> It's probably using another version of the activity in your path or

No, I've tried many times on several machines with the same result.

> If you fix that in addition to exec, then it works for me.
> [Activity]
> name = Tuxmath
> activity_version = 2
> bundle_id = org.ceibaljam.Tuxmath
> icon = tuxmath-sugar-icon
> exec = sugar-activity activity.TuxmathStart

I will try to install in a packaged patch.


More information about the Sugar-devel mailing list