[Sugar-devel] Testing Summary: Auckland NZ - 9 October 2010

Tabitha Roder tabitha at tabitha.net.nz
Sat Oct 9 02:19:24 EDT 2010

Testing Summary: Auckland NZ - 9 October 2010

Who: Abhishek, Charlotte, Fabiana, John, Leslie, Robin, Tabitha, Tom

Tested Sugar 0.90 on XO-1.5 x 2
No restart button only shutdown :-(
Frame key works. Opened physics. Drop a circle in the activity and it
crashes Physics. (Known issue #2363 I guess.) Frame key no longer works
(known issue #2415 most likely), but frame appears when you point in the

TurtleArt started okay.
Joined local wifi successfully, Browse activity allowed clicking on links on
the homepage but couldn't type in the search fields. Can type in url field
and can use search fields within pages on other pages, just not on home
page. Reproduced failure of home page search fields in a second browse

Speak 15
Believes the pope is john paul 2.

Works as expected.

>From Fabiana

> memorize 35 testing:
> 2 computers (X1.5, Build 5 customised, Sugar 0.90.0)
> Poppy & Tank
> Initially, Poppy started a memorize activity. Tank joined and they were
> able to collaborate (I think both computers were on a ad-hoc network). Poppy
> quit memorise, but the icon on the desktop remained. On Tank, I created a
> customised activity, which I was able to play with by myself.
> Poppy and Tank then both went onto the wifi network. Tank put the
> customised activity on share on neighbourhood, but while Poppy could see the
> icon for tank, it could not see the memorise activity (tank could see the
> memorise sharing icon on its own neighbourhood). Tank tried to invite poppy,
> but that didnt work either. Restarting tank and trying again didnt work
> either. Tank then clicked on Poppy's old shared icon (poppy did not have
> memorise open) and it looked like it had joined. When poppy also clicked on
> that icon, it showed tank on the on the top as if tank had started the
> sharing. No sharing could take place.
> Speak version 18 seems ok
> Turtle blocks version 99 seems ok, but it is annoying that the pallette is
> not floating, need to scroll up and down to get artifacts as the sequence
> gets longer
> etoys version 116 Dont know how to use. Made a drawing, but then after
> stopping the activity it wasnt shown in the activity circle as having been
> used.


Tested activities on XO-1.0s
Quite cool when we worked out what to do (should have read the
instructions). The ten year old tester says the magician is creepy and it is
really hard. She understood that she had to enter 1 number then it would
turn before the next number. She got the first couple of numbers but third
number onwards was particularly hard. The adult tester said steep learning
curve, interesting the collaboration was happening outside of the computer
(we all talked to work out how it worked and we think this is a very good
valuable thing).

Pulsing icon of death, didn't start. Got logs. Raised sugarlabs ticket

Easy levels make for happy testing for the ten year old and the adults :-)
Moved onto harder levels. Took a bit more to nut out how it worked but got
there, good challenge. Too hard for the ten year old, she lost interest.

Could not test as seems we have to have a midi controller to plug in.
We were a bit surprised to open a Sugar activity and see loads of text on
the screen. Can this be presented better? What if you can't read all that or
there is no local translation?

Juegos Flash 2
First tab is "whack your ex" - not appropriate at all for children. The
animations are horrific and the ten year old said "and that is why you guys
test things".
We found another inappropriate activity - "the right mix" for cocktail
There is no stop button to end the activity. We were not sure of the
educational value of this activity but we had lots of trouble with memory on
the XOs and with language.

Confirmed it does take values across the Abaci where it can. Can it say when
it is not valid? e.g. sorry that cannot be translated. Part of the problem
is where the number is left of decimal but get no failure message when
Abacus is all on the right of the decimal point.

Turtleart -99
Showed Charlotte turning around on the spot 180, 360, then got her to work
out how much it would be to turn right (90) and left (90). Once that was
sorted we wrote a programme. She made a repeating pattern (came out looking
like a big wide cross) with repeat 4, forward right forward left forward
right varying steps. She then worked out how to make a square and a bigger
square. Then she worked out the repeats in her formula (4). Tried making a
triangle. Interesting corrective behaviour. She wrote R45, F100, R135, F100,
R90, F100. When it didnt match she chose to add R135, F30 (there was some
trial and error on the last R angle) rather than adjust her original
Turtle art got so slow on the XO-1.0 that she ended up making mistakes
because the drag responded too slow.

Charlotte tested the eToys demon castle tutorial. Then she tried some
challenges. When trying to quit the activity seemed to save for ages, bring
up an error message then proceed to make the XO very unhappy.


Tested soas-i386-20101007.16.iso in virtualbox.
Didn't attempt to make a bootable usb, just booted the iso in virtualbox.
Physics 5 crashed as on XO.
Record 66 didn't work even when making the macbook's built in camera
available to virtualbox. We just got a black window with no picture. The
light did come on next to the camera on the macbook.
Browse 117 opens with a local start page and like the XO start page, you
cannot enter text into the google search box at the bottom of the page. If
type a url into the url bar or follow a link, then text boxes work. If you
go back to the homepage the google search box works.

Thanks testers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sugarlabs.org/archive/sugar-devel/attachments/20101009/cbc015f2/attachment-0001.html>

More information about the Sugar-devel mailing list