[Sugar-devel] Restoring journal backups created with 0.82 on 0.84

Tomeu Vizoso tomeu at tomeuvizoso.net
Mon Mar 22 05:06:34 EDT 2010

On Tue, Mar 16, 2010 at 20:13, Bernie Innocenti <bernie at codewiz.org> wrote:
> Martin, Rodolfo
> Aldo, one of the technicians in Caacupe, reported failure to restore
> backups created with Sugar 0.82 after the machine has been upgraded to
> Sugar 0.84.
> Frankly, I don't understand how the restore script is supposed to work:
> it rsyncs the files into ~/.ds-restore-tmp and then quits without moving
> them where the datastore is.
> I tried moving the files manually into ~/.sugar/default/datastore and
> restarting Sugar, but nothing shows up. How does the datastore detect an
> old format that needs updating?

See http://git.sugarlabs.org/projects/sugar-datastore/repos/mainline/blobs/sucrose-0.84/src/carquinyol/datastore.py#line57

> Besides this problem, it would be useful to add a control panel icon for
> listing available backups and restoring them. Is anyone working on this?

Would be good if all deployments agreed on a common backup system and
worked together on this.



> --
>   // Bernie Innocenti - http://codewiz.org/
>  \X/  Sugar Labs       - http://sugarlabs.org/
> _______________________________________________
> Sugar-devel mailing list
> Sugar-devel at lists.sugarlabs.org
> http://lists.sugarlabs.org/listinfo/sugar-devel

More information about the Sugar-devel mailing list