[Sugar-devel] New F11 for the XO-1 Build 9

Jim Simmons nicestep at gmail.com
Thu Nov 26 19:33:57 EST 2009


I tried out build 9.  It works for me, but has the following issues:

1).  You MUST hold down the check button to get it to boot.  If you
don't it goes to the "pretty boot" image with one dot and just hangs
2).  The gstreamer espeak plugin does not appear to be installed.  The
Activity Read Etexts uses this to provide text to speech with word
highlighting.  I imagine many other Activities would find it useful as
3).  When the XO has been inactive for awhile, instead of blanking the
sceen the screen gets filled with horizontal lines.
4).  The Terminal Activity is not included.  I was able to get this
Activity from ASLO and install it and it seemed to work fine.
5).  I was able to use yum install to install the missing gstreamer
plugin for espeak.  It had a memory allocation problem in the post
install script but seemed to be installed OK.  Read Etexts recognized
it and I was able to do speech with word highlghting.
6).  HOWEVER, the words highlighted lagged far behind the words
spoken.  The gstreamer plugin sends a callback just before speaking a
word, and my program doesn't take that long to highlight a word, so
something must be interfereing with the gstreamer plugin.   This has
occasionally been a problem with SoaS too.
7).  I tried switching to the GNOME environment and found it quite
useable.   One problem I found was that the "preferred browser" icon
in the top menu bar points to Firefox instead of Midori.
8).  I needed to copy things from a USB thumb drive or an SD card to
the Journal.  This is normally done by going into the information page
of the file in question and selecting "To Journal" from the Copy menu.
 However that option was missing.  I was able to work around that lack
by doing a Copy to the Clipboard then doing a Keep on it, but that is
NOT a satisfactory substitute.  For one thing, the name of the file
does not get copied to the Journal title.  Instead you get a generic
title that gives no indication of what was copied.
9).  I tried to open a .cbz (Comic Book Archive) file with Read.  Read
could not handle it and failed, probably due to a missing evince
plugin.  I tried doing a yum search to find the plugin and install it
and it was not listed in the search results.  Read can also do EPUBs
if you have the right binaries installed, and I would guess these are
missing as well.  I didn't try it.

Some significant problems, but not bad enough for me to roll back to
.82 just yet.  Should be well worth an upgrade when finished.

James Simmons

> Date: Mon, 23 Nov 2009 16:01:44 -0500
> From: "Steven M. Parrish" <smparrish at gmail.com>
> Subject: [Sugar-devel] New F11 for the XO-1 Build 9
> Today I have released build 9 for the XO-1.
> This release will require you to flash it onto your XO-1 so you will loose
> everything.  Please be sure to backup you home directory before installing.
> Release notes can be found here
> http://wiki.laptop.org/go/F11_for_XO-1#Current_release:__OS9
> Enjoy.
> --
>  =====================================================
>  Steven M. Parrish

More information about the Sugar-devel mailing list