[Sugar-devel] Problems with Read Activity on XO

Jim Simmons nicestep at gmail.com
Wed Nov 4 16:05:48 EST 2009


Didn't see any evidence of segfault in dmesg or shell.log.  However, I
tried out:

sugar-launch org.laptop.sugar.ReadActivity

and it worked beautifully.  Read gave me that ugly dialog that lets
you select a document from the Journal, I selected one of the PDFs,
and it loaded right up.  Everything worked just fine, and it created a
Journal entry called "Unknown" with the Read icon on it.  When I try
to resume from the Journal, either the new entry or one of the
original PDFs, I get the symptoms I described before.

I *might* be able to launch Read from the Activity Ring.  I turned off
my XO and put it away before I thought to try it.  (I'm at work).

So it looks to me that there is nothing wrong with Read itself, but
there might be something wrong with how its installed.


James Simmons

On Wed, Nov 4, 2009 at 2:09 PM, Sayamindu Dasgupta <sayamindu at gmail.com> wrote:
> It may be possible is something is segfaulting (I vaguely remember
> seeing something like this). dmesg usually keeps track of things that
> segfault, and you can also take a look at shell.log
> Another way would be to use the Terminal:
> sugar-launch org.laptop.sugar.ReadActivity
> Thanks,
> Sayamindu

More information about the Sugar-devel mailing list