[Sugar-devel] The Road to SoaS-2: A new Snapshot!

Sebastian Dziallas sebastian at when.com
Thu Mar 5 09:03:26 EST 2009

Ton van Overbeek wrote:
> Generated the usb stick on Windows using liveusb-creator 3.2 with the '-x'
> option to get the boot/olpc.fth file. Edited the olpc.fth file to get
> rid of the extraneous
> backslashes (Luke already fixed this in git, but no updated windows version of
> liveusb-creator has been created yet).
> First tried to boot it on my Dell laptop (Precision M60, Pentium-M,
> 1920x1200 res).
> Got the three bars to complete, but then a blank screen and no X
> windows. no Sugar.
> Could not get a text console (Ctrl-Alt-F[1-6] did not work).

Mh, this is interesting. We'll need to look into that, but sounds like 
an issue with F11 / Rawhide right now.

> Then reflashed the stick and tried to boot it on the XO.
> Got the nice graphical plymouth boot which took a loooooooooong time to complete
> (much much longer than a SoaS-1 image). Again a blank screen and no X.
> Here I could get to the text consoles. Noticed there was a cursor which could
> be moved over the screen with the XO touchpad.
> dmesg did not show any obvious clues.
> Xorg.0.log showed at the end:
> -----------------
> (II) GEODE: Driver for AMD Geode Chipsets: Geode LX, Geode GX
> (EE) No devices detected.
> Fatal server error:
> no screen found
> -----------------
> The XO specific xorg.conf file was created in /etc/X11 and read
> by the X server..

Okay, this has recently been fixed and should work again on the XO by 
today. So we'll be publishing an updated snapshot later today...

> All in all not very successful.
> I hope you can use this info.
> Ton van Overbeek

Yeah! Thanks a lot for giving it a test drive... :)


More information about the Sugar-devel mailing list