[Sugar-devel] Issues with mesh network on XO 1.5

Martin Langhoff martin.langhoff at gmail.com
Fri Dec 4 10:01:00 EST 2009

On Fri, Dec 4, 2009 at 3:47 PM, Grivan Thapar <grivan.ozone at gmail.com> wrote:
> and OLPC release 11 (Leonidas)  XO 1.5

That's not the build number. `cat /boot/olpc_build ` will give you the
build number. This stuff is under heavy development, so if you are
using an old build your bug reports are not very useful -- see here to
get a recent build: http://wiki.laptop.org/go/F11_for_1.5

> Also, "olpc-netlogs"  is
> this a command on terminal? As it doesn't seems to be working at my end.

On the XO-1 with build 8.2.0 it is called "olpc-netlog". On the XO-1.5
with a recent build, it is has been renamed to "olpc-log".

> Anyway I have copied the logs from /var/log/wpa_supplicant.log, which seemed
> to contain all the network related information.

Cool -- please file it as a bug in dev.laptop.org

> The XO1.5 logs show the testing with a XO 1, the XO1.5 does recognize a
> 'olpc-mesh' and connects too but we could not collaborate between the
> activities. Secondly when we tried to create a new network from XO1.5 the
> XO1 is not able to find this new network.

Please get an account on dev.laptop.org and file it as a bug there
(probably 2 separate bugs).

There are very few XO-1.5s around, so your help is needed. Very
important that you get an account on dev.laptop.org, download a
current version of the 1.5 OS and retest based on that.

> Then we tried to connect to this network from the SOAS running on a acer
> laptop. It does find this network i.e 'gri's network'.

And that's probably a 3rd bug :-)

 martin.langhoff at gmail.com
 martin at laptop.org -- School Server Architect
 - ask interesting questions
 - don't get distracted with shiny stuff  - working code first
 - http://wiki.laptop.org/go/User:Martinlanghoff

More information about the Sugar-devel mailing list