[IAEP] [Testing] 12-Year-Old XOs (even 18-yesr-olds)

James Cameron quozl at laptop.org
Mon Aug 29 00:49:22 EDT 2011

On Sun, Aug 28, 2011 at 09:16:38PM -0700, Caryl Bigenho wrote:
> What I ran into in the process was pretty wild!

Entirely normal, and a result of your decision not to reflash.

> Some of the machines worked fine. I was even able to add Labyrinth and
> Fototoon to several of them.  On one, I was actually able to install a
> developer key.  However, I got some strange error messages and really
> unusual Journal entries on others.
> For example, some of the laptops were trying to go to a place called
> "activation.laptop.org" when I signed on ...

Yes, activation.laptop.org is where the developer key infrastructure is.

Only they can explain why they went to activation.laptop.org, I think,
but chances are they were trying to get a developer key.

> ... and tried to go to the Activities page (see image 1).  It offered
> the option of "adding an exception", but that didn't work.

Yes, it doesn't work in that version of Browse.  Upgrade the version of
Browse first, if you wish to try that again, otherwise reflash.

> However, surprise, the Back button took me to the Activities page
> where I was able to download Labyrinth and Fototoon.

That doesn't address your need to get a developer key, and nor does
reflashing, by the way.  But once you have got one, you can turn off
deployment delivery anti-theft security, and that makes it easier for
you to deal with the laptops.

> On some of the laptops I was not able to access the internet at all.
> See image2.

Looks like either the laptop isn't connected to an ethernet or wireless
network, or the connection between the local network and the internet is
so heavily used that the laptop was not able to resolve a web site name.

Or, you don't really want to access img.cs.montana.edu and what really
happened was that you got taken to the previous web page used by the
previous user!

If so, this is because you clicked on the coloured Browse icon in the
home view instead of right-click to start new, or use it from the list

Only they can explain why they went to img.cs.montana.edu, and perhaps
it isn't interesting at all.

Had you cleaned out the journals first, you would not have faced this
allegation of failure.

> Later, when I looked at the Journal entries on some of the machines, I
> found they were incredibly old.... like 12 years! (Image3). There was
> one that said "18 years ago" also, but I seem to have misplaced the
> image.

That is easily explained.  Either the clock on the laptop has advanced
to next decade, or the download was done when the clock on the laptop
was set to a decade ago.  Why should you care?  It's part of the
journal.  Again, it shows why it is necessary to clear out the journal.

> One more image... When I clicked on the Browse icon on many of the
> machines I got the choices shown in Image4. I haven't encountered the
> "OLPC Activation Service" before. Tell me about it....

You would have created that journal entry by asking for a developer key
... or the person who used the laptop before you might have done it.

> I think I will take the easy way out and just do the reflash update
> from a usb drive and then transfer the Activities I want to add from a
> usb drive.

Yes, that's another way to clean out the journal.

> I am curious, however, about these strange things that were happening.
> I also wonder if I will have problems with the reflashing.

You may well have problems with the reflashing, but it won't be because
of the existing journal, it gets wiped by a full reflash.

Why did some of the laptops work the way you expected them to?  Sad
news; it means they were never touched between when you flashed them and
when you got them back!

James Cameron

More information about the IAEP mailing list