[Dextrose] Display not occurring on a "osuilder" dx2-xo1 build

Anish Mangal anish at sugarlabs.org
Thu Nov 3 05:04:17 EDT 2011

Hash: SHA1

On 11/01/2011 05:49 PM, Sascha Silbe wrote:
> Excerpts from Ajay Garg's message of 2011-10-25 15:53:52 +0200:
>> b. Put a hack, to install "sugar-0.88", and not "sugar-0.84".
> Are you sure plain Fedora 11 has recent enough versions of all
> dependencies required by Sugar 0.88? A quick glance at 
> examples/f11-0.88-xo1-py-nognome.ini and the dextrose-f11-0.88 used
> in there suggests you'd have to pull in at least some backports.

hmm... we had backported a few rpms which are present in the dxo2
repo... it maybe a question that somebody has removed some more rpm's
from the official fedora repos.. I guess it should be checked that all
dependencies are satisfied.

>> 9. The bootup got going, however the display wudn't come up.
>> 10. On the sugarless-terminal, I switched to "olpc" login.
>> 11. Tried running sugar manually; however the following
>> stacktarce was observed :
> [...]
> I take this to mean that you tried running sugar from a Linux
> virtual console in text mode, i.e. outside of X. Since Sugar builds
> on X, this can't work and explains the errors you ran into.
> Unfortunately olpc-dm sends all error messages to /dev/null by
> default, making it unnecessarily hard to diagnose this kind of
> problem. You could, however, start xterm instead of sugar in
> ~olpc/.xsession and run sugar manually from inside the xterm to see
> the errors.
> Sascha
> _______________________________________________ Dextrose mailing
> list Dextrose at lists.sugarlabs.org 
> http://lists.sugarlabs.org/listinfo/dextrose

- -- 
Anish Mangal
Sugar Labs
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Dextrose mailing list