[Dextrose] Display not occurring on a "osuilder" dx2-xo1 build

Sascha Silbe sascha-ml-reply-to-2011-4 at silbe.org
Tue Nov 1 08:19:01 EDT 2011

Excerpts from Ajay Garg's message of 2011-10-25 15:53:52 +0200:

>     b. Put a hack, to install "sugar-0.88", and not "sugar-0.84".

Are you sure plain Fedora 11 has recent enough versions of all dependencies
required by Sugar 0.88? A quick glance at
examples/f11-0.88-xo1-py-nognome.ini and the dextrose-f11-0.88 used in
there suggests you'd have to pull in at least some backports.

> 9. The bootup got going, however the display wudn't come up.
> 10. On the sugarless-terminal, I switched to "olpc" login.
> 11. Tried running sugar manually; however the following stacktarce was
> observed :


I take this to mean that you tried running sugar from a Linux virtual
console in text mode, i.e. outside of X. Since Sugar builds on X, this
can't work and explains the errors you ran into.

Unfortunately olpc-dm sends all error messages to /dev/null by default,
making it unnecessarily hard to diagnose this kind of problem. You
could, however, start xterm instead of sugar in ~olpc/.xsession and run
sugar manually from inside the xterm to see the errors.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://lists.sugarlabs.org/archive/dextrose/attachments/20111101/dff3cdee/attachment.pgp>

More information about the Dextrose mailing list