[Dextrose] [Fwd: Testing summary - Auckland New Zealand, 22 January 2011]

Bernie Innocenti bernie at codewiz.org
Sat Jan 22 17:17:44 EST 2011

The amazing OLPC-NZ testing team hits again!

Rafael will look at these bugs over the next few weeks. It's important
that we report our progress to Tabitha & Co.

Steven, it would be nice if you could keep track of the status of these
bugs in the release notes of the next builds. Crediting the reporter
would also be cool, if it's not too much overhead for you.

-------- Forwarded Message --------
From: Tabitha Roder <tabitha at tabitha.net.nz>
To: OLPC testing <testing at lists.laptop.org>, olpc-nz at lists.laptop.org,
bernie.codewiz at gmail.com, Steven Parrish <smparrish at gmail.com>
Subject: Testing summary - Auckland New Zealand, 22 January 2011
Date: Sat, 22 Jan 2011 18:22:44 +1300

Testing summary - Auckland New Zealand, 22 January 2011

Who: Carl (visiting from Wellington), Ella (aged 9), Leslie, Peter,
Tabitha, Tom

os439dx on XO-1.0 & XO-1.5

Maze on 1.0
Game works, all three controllers work
Rotate fail - doesn't resize on 90 and 270 to fit the screen
collaborate between two XO-1.0s on adhoc network 1

Paint on 1.0
All the tools and shapes worked, as well as text. 
Rotate fail - doesn't resize to fit on 90 and 270
Can add photo from journal
This was the first activity that the 9 year old chose I think (on a 1.5)
- it was her first time using the XO

Implode on 1.0
Played two levels successfully
Rotate works, fits screen

Speak on 1.0 and 1.5
can change eyes, mouth, pitch and rate
robot says it cant speak "english us" lets speak english instead. Is
this an improvement over SL#2103??
On XO-1.0 robot cant answer any questions, not even what is your name,
it says sorry a lot
On XO-1.5 robot knows it's own name but when you ask where it was born,
it says "alice was born in" reported SL#2566.
voice chat works on 1.0 (forgot to check on 1.5)

Tam tam mini on 1.0
all good, though rotate doesn't resize

Log on 1.0 
Doesn't show logs from before X was killed by out of memory, have to use
terminal for logs from previous session

Terminal on 1.0 and 1.5
did what needed

Write on 1.0 and 1.5
first attempt at collaboration failed miserably with everyone having
different versions
second attempt was great - five XO-1.0s and one XO-1.5

Memorize on 1.0
Two player shared game - checked on addition and letters
Played user created game too, shared worked. Tested loading user created
game before sharing and confirmed that it worked successfully. 

Tam tam jam on 1.0
all good

Scratch on 1.0
wrote very basic script and it worked, but this activity still does not
look very sugar like

Typing Turtle on 1.0
did alphabet balloons and got a gold medal, but wonder where the word
list comes from as we tried to see if between us we knew all the words,
should it use words that kids learn in primary school?

Finance on 1.0 and 1.5
Need to have keyboard shortcuts - tab should move to next field. Gaming
keys might be trying to do this but they don't highlight fields as you
press the left gaming keys.
In view if you choose chart, when you go back to transaction it just
keeps the chart open, have to change view back to register
Budget view gives you summary of categories rather than option to create
a budget, felt weird to the testers who thought of a budget as a future
word rather than a past tense word

Chat on 1.0
insert smiley doesn't insert and hard to read tooltips as the keyboard
shortcut is hidden by the cursor
could collaborate between 1.0s

Abacus on 1.5
Configuration bar doesn't appear to configure anything. You can type
numbers in, but it doesn't effect anything.

Arithmetic on 1.5
seems to work, gives correct feedback (well, if we can add correctly),
tried several difficulties and puzzles, even had negative integer

Words on 1.5
Words has got confused. When you choose english to german, it actually
does german to english.

Record on 1.0 and 1.5
Took pictures successfully, did not further test. 

File transfer with Journal send to friend seemed to work, but wasn't
able to view at the recipient due to the next problem.

Can't view images in the journal using image viewer. On XO-1.0 X
consumes all the memory and is eventually killed. On XO-1.5, X consumes
about 250MB memory (as displayed in top) and between them image viewer
and X consume all the cpu. This is reproducible every time with images
from record. I obtained the output of top from an XO-1.0 before the OOM
killer sprang into action by logging in with ssh prior to reproducing:
top - 22:58:34 up 19 min,  2 users,  load average: 0.63, 0.58, 0.54
Tasks:  71 total,   3 running,  68 sleeping,   0 stopped,   0 zombie
Cpu(s): 43.9%us, 17.2%sy,  0.0%ni,  0.0%id, 38.9%wa,  0.0%hi,  0.0%si,
Mem:    221868k total,   218588k used,     3280k free,        0k buffers
Swap:        0k total,        0k used,        0k free,    18600k cached

2631 root      20   0  152m 116m 1816 S 48.1 53.9   0:18.18
1448 root      30  10     0    0    0 R  6.6  0.0   0:12.01
2844 olpc      20   0  6812 1788 1124 D  2.6  0.8   0:00.67
3230 olpc      20   0 42108  22m   9m R  2.6 10.4   0:04.70 Image Viewer
3202 olpc      20   0  2404  716  520 R  0.7  0.3   0:00.68
1848 root      20   0  1848  152   96 S  0.3  0.1   0:00.54
   1 root      20   0  1996  444  236 S  0.0  0.2   0:01.30

Raised SL#2567

Physics still suffers from SL#2512

Measure still suffers from SL#2203 and on XO-1.5 suffers from SL#2509,

Collaboration seems better than au852-4 we tested last week, but it
still doesn't work reliably. We had ivy able to see monkey, but monkey
unable to see ivy. Tux could see monkey, but couldn't see couldn't see
monkey's shared chat activity. XO 1.0 and XO 1.5 on adhoc networking.
How do we diagnose this?

No wikipedia activity - Can this be added again please?

Still suffers from SL#2511
No tabbed browsing :(

See attached for power logs.

Thanks testers

   // Bernie Innocenti - http://codewiz.org/
 \X/  Sugar Labs       - http://sugarlabs.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: power-logs.tar.bz2
Type: application/x-bzip2
Size: 14144 bytes
Desc: not available
URL: <http://lists.sugarlabs.org/archive/dextrose/attachments/20110122/37b17efc/attachment.bin>

More information about the Dextrose mailing list